Site blog

Page: () 1 2 3 ()
Anyone in the world

在Ubuntu中常用的apache為apache2,而設定檔案在/etc/apache2/apache2.conf,預設安裝完成apache2後,網頁目錄瀏覽的講能是開啟的,這是比較不安全的,所以可以從apache2conf中修改之,修改方式如下,將,但是要注意的是apache2.x中在Options 後面接的選項不只一個時,當其中有任何一個以「加減號」做為啟動或關閉時,則其他每個選項也都要在前面加上「加減號」,否則apache2會無法成功啟動!!

f01

改完後再動新啟動apache2即可

#service apache2 restart

 

 
Picture of 管理者 使用者
by 管理者 使用者 - Friday, 4 March 2016, 10:59 AM
Anyone in the world

近來許多電腦被綁架的事情發生(也算電腦中毒的一種),某網路使用者:「所有檔案都被加密,然後電腦裡面的資料全部都打不開,它說要打開的話必須付費才行。」所有程式通通打不開,照片影片的檔案通通也無法使用了…

[線上資訊1][線上資訊2][線上資訊3][線上資訊4][線上資訊5][線上資訊6-追劇中獎]

[檔案加密可能解法!!] [趨勢科技官方說明]

如何防止參考線上video!!

 

下面是遇到友人的電腦狀況

f01

f02

f03

檔案格式被改變,因為windows也無法判別出相關格式出現成白色的icon

f05

 

有問題的Mail、line、skype案例

f03

f04

f05

[ Modified: Tuesday, 4 April 2017, 3:25 PM ]
 
Picture of 管理者 使用者
by 管理者 使用者 - Tuesday, 1 March 2016, 8:52 PM
Anyone in the world

現在mail傳送,常常會有壓縮檔,有的還加密,如果遇到加密的,預設mailscanner會直接過濾掉,因此可以修改設定來放行

f01

# nano /etc/MailScanner/MailScanner.conf

# Should archives which contain any password-protected files be allowed?
# Leaving this set to "no" is a good way of protecting against all the
# protected zip files used by viruses at the moment.
# This can also be the filename of a ruleset.
Allow Password-Protected Archives = yes (預設是no,改為yes即可放行)
 
Picture of 管理者 使用者
by 管理者 使用者 - Wednesday, 24 February 2016, 8:19 PM
Anyone in the world

由於moodle持續會有版本更新,此外配合資料庫、php、web等程式更改都會有更新的狀況,所以每次更新時,可能會有不同的狀況,好處時透過moodle新的版本更新時的說明就可以直接進行解決,今天發現寒假時裝的3.0.2+(原來是20160211的版本)在上週居然又出了stable的版本,所以就想說直接來更新看看,在系統中也出現部分table需要調整的狀況如下圖

f01

雖然可以持續更新,不過就來了解一下是什麼問題,主要也是因為現在MySQL的儲存機制作調整的原因,因此moodle線上有說明內容 ,透過moodle的內建php在本機執行即可

# /usr/bin/php admin/cli/mysql_compressed_rows.php -l (來確認那些table有問題)

# /usr/bin/php admin/cli/mysql_compressed_rows.php -f (來進行修正)

f02

 
Picture of 管理者 使用者
by 管理者 使用者 - Tuesday, 23 February 2016, 10:14 AM
Anyone in the world

最近更新到moodle3.0.2+後發現,原來作的相關線上課程中有mp4的影音檔在透過firefox browser來觀看時,會有自動播放的狀況,而且是獨立的聲音,感覺是另外的軟體在播放聲音,為了避免困擾,google了一會,發現沒有相同的狀況,不過到時找到在「網站管理」中「外觀」中「多媒體嵌入」的選項中有一個結合Quicktime的選項,如果將其打勾選消就會正常,看來那個多的聲音應該是quicktime造成的!!

fig01

 
Picture of 管理者 使用者
by 管理者 使用者 - Sunday, 21 February 2016, 6:28 AM
Anyone in the world

openwebmail是一個歷史悠久的webmail,個人用了許久,還不錯用,相關設定可以參考個人網頁,如果需要調整mail出去時的附檔大小,可以透過如下修改設定檔:

# nano /var/www/cgi-bin/openwebmail/etc/openwebmail.conf

attlimit                10000 (預設是500000, 50MB)
[ Modified: Sunday, 21 February 2016, 6:28 AM ]
 
Picture of 管理者 使用者
by 管理者 使用者 - Tuesday, 16 February 2016, 6:33 PM
Anyone in the world

每次重裝主機後,小弟自建的mail server就需要重新config,在MailScanner上可以協助mail作病毒、spam等過濾,不過難免會誤判,因此可以透過白名單的方式進行pass,設定方式如下:

先確認config檔是否有啟動spam白名單之功能

# cat or more or nano /etc/MailScanner/MailScanner.conf

f01

找到Is Definitely Not Spam = %rules-dir%/spam.whitelist.rules這一行設定是否ok(如上圖紅色框內)

如果ok就去修改spam.whitelist.rules

# nano /etc/MailScanner/rules/spam.whitelist.rules

加上希望pass的網址、mail或是IP

常用語法
  對象
  From:     針對信件的寄件者進行比對
  To:     針對信件的收件者進行比對
  FromOrTo:     針對寄件者或收件者進行比對
  FromAndTo:     針對寄件者及收件者共同進行比對

  比對的樣本
  user@sub.domain.com     單一的郵件位址
  user@*     單一帳號(不限定領域)
  *@*.domain.com     domain.com下轄 subdomin下的任何帳號
  *@donain.com     特定 domain.com 的任何帳號
  192.168.     SMTP client IP 範圍 192.168.0.0/16
  /^192.168.1[4567]./     SMTP client IP 範圍 192.168.14~17

 

小弟範例

From: *@ntupes.edu.tw yes

設定學校來的mail都pass

 

# systemctl restart MailScanner.service (重新啟動mailscanner即可)

[ Modified: Tuesday, 16 February 2016, 6:35 PM ]
 
Picture of 管理者 使用者
by 管理者 使用者 - Tuesday, 16 February 2016, 6:03 PM
Anyone in the world

多年架設了一個lifetype的部落格,最近主機重裝為ubuntu15.10,所以系統搬移後,就忘記之前的設定,在lifetype中可以用簡短網址來呈現內容

f01

如果在apache中沒有設定的話,是無法直接用簡短網址的,會出現如下圖的狀況

f02

在ubuntu中apache是用apache2的名稱,修改設定如下:

# nano /etc/apache2/apache2.conf

<Directory /var/www/html/weblog/>
        Options Multiviews
        AllowOverride All
        Order allow,deny
        Allow from all
</Directory>

上面藍色字是lifetype所在位置的網對路徑目錄

 

# service apache2 restart

 
Picture of 管理者 使用者
by 管理者 使用者 - Tuesday, 16 February 2016, 9:53 AM
Anyone in the world

最近聽朋友說遇到一個問題,在網站某個目錄之下,直接用目錄list之方式顯示index.php的程式,似乎沒有執行此index.php程式(如下圖),有可能幾個原因進行討論,環境都以CentOS7x為例

f01

1.此台linux上面沒有安裝php的套件

參考解法,透過yum安裝php套件

# yum -y install php php-mysqlyum php-pdo php-gd php-ldap php-odbc php-pear.noarch php-xml php-xmlrpc php-mbstring php-snmp php-soap php-mcrypt curl curl-devel libxml2 libxml2-devel curl curl-devel libjpeg libjpeg-devel libpng libpng-devel libmcrypt libmcrypt-devel libtool-ltdl-devel

# yum -y install *php* (比較快的方法,直接將php相關套件都安裝起來,但是有可能多裝了不少套件!!)

# systemctl restart httpd.service (php安裝後要重啟apache)

2.apache httpd設定中沒有指定預設目錄執行檔案

參考解法,透過修改httpd.conf中是否有下面藍色框中加上index.php(通常也會再加上index.htm or index,html)設定目錄預設中有那些檔案時可以自動執行

# nano /etc/httpd/conf/httpd.conf

<IfModule dir_module>
DirectoryIndex index.php index.htm
</IfModule>

# systemctl restart httpd.service (httpd.conf修改完後要重啟apache)

3.apache httpd設定預設目錄沒有對應執行檔案時會顯示目錄,這是不安全的設定

參考解法,透過修改httpd.conf中如設定目錄預設中沒有可以直接執行的檔案時,不要顯示目錄

# nano /etc/httpd/conf/httpd.conf

先找到<Directory "/var/www/html">這一行
然後將Options Indexes FollowSymLinks中

f03

# systemctl restart httpd.service (httpd.conf修改完後要重啟apache)

就可以看到如下的狀況了!!

f02

[ Modified: Tuesday, 16 February 2016, 9:54 AM ]
 
Picture of 管理者 使用者
by 管理者 使用者 - Saturday, 13 February 2016, 7:47 AM
Anyone in the world

每到了寒暑假,就要為自行架設的moodle主機進行升級了,目前最新的是Moodle 3.0.2+的套件,moodle升級其實也很容易,只要先記得先備份原來的web程式和db即可

備份web及更名folder

# tar zcvf moodle_2016xxxx.tar.gz /var/www/html/moodle

# mv /var/www/html/moodle /var/www/html/moodle_backup

備份db

# mysqldump -u root -p DB_name > DB_backup_name.sql

dbdump

上網下載最新的moodle,目前是3.0.2+

# cd /var/www/html

# wget https://download.moodle.org/download.php/stable30/moodle-latest-30.tgz

# tar zxvf moodle-latest-30.tgz

# cp /var/www/html/moodle_backup/config.php /var/www/html/moodle

# chown -R webuser.webuser /var/www/html/moodle (將moodle的目錄設定給web的管理者所擁有)

# chmod -R 755 /var/www/html/moodle

# crontab -e -u root (設定cron.php每天早上08:20執行一次,以便提升moodle網站的memory使用效能,如果升級前有設定過了,基本上就可以延用)

20 8 * * * /usr/bin/php /var/www/html/moodle/admin/cli/cron.php

 

再來就透過web畫面進行升級即可,有可能會出現一些錯誤訊息,可能少了一些php相關套件,就再透過yum install xxx來安裝即可(如果在ubuntu時,用aptitude install xxx)

升級到2.9 or 3.0以上的版本,有可能MySQL的資料庫需要修改storage的機制,在moodle中有準備了一個程式可以協助原來舊版moodle的db一次改為innoDB的作法如下:

# /usr/bin/php /var/www/html/moodle/admin/cli/mysql_engine.php --engine=InnoDB

[ Modified: Sunday, 14 February 2016, 9:37 AM ]
 
Page: () 1 2 3 ()