Eating weblog

Google的資料更新及刪除

資訊科技 — 作者 wkb @ 12:08

如果發現個人資料被google連結並有cache住時,可以透過下面方式進行處理!!

http://briian.com/?p=5832


WiFi power saving mode

研究心得 — 作者 wkb @ 10:27

wifi client要進入 power saving mode時只需要等一次beacon interval即可,而beacon interval default是100 ms。而viop traffic has high burstiness 的特性,而一般voip的traffic平常就有silent interval 200ms~300ms。

http://sky.csie.org/sky/archives/000040.html


Good websit for travel

生活點滴 — 作者 wkb @ 07:15

這個網站,有不錯的資訊在此網站如:住宿、購買飛機票等資訊!!

http://www.kayak.com/


Cisco nat setup

資訊科技 — 作者 wkb @ 12:11

可以在router上作NAT和PATr的功能

設定dynamic nat (虛擬ip和實體ip一對一的方式但是不是固定的對應)

#conf t

)#ip nat pool d_nat 200.2.2.10 200.2.2.200 netmask 255.255.255.0 (d_nat是表示pool的name可以任意修改,200.2.2.10 200.2.2.200是表示那些要對應的實體ip,255.255.255.0是這個實體ip的netmask)

)#access-list 10 permit 192.168.3.0 0.0.0.255 (這是設定要被處理的那些虛擬ip網段)

)#ip nat inside source list 10 pool d_nat (這是將上面的實體ip的pool和允許要進行map之虛擬ip的網段作結合,這樣router才知道要作nat)

)#int fa 0/0     (設定完上面的對應後,要在lan port上設inside,在wan port上設outside,如果有多個lan,一個wan,每個lan都要設inside,然後在wan上outside)

)#ip nat inside

)#int se 0/0/1

)#ip nat outside

 

如果是設定static nat (虛擬ip和實體ip一對一固定的對應)  

)#ip nat inside source static 10.0.0.1 190.0.0.1 (前面的ip粉紅色的是虛擬的ip,後面藍色的ip是實體的ip)

 

設定pat (虛擬ip和實體ip多對一的方式)

不過pat有兩種作法一個是透過一個pool中的實體ip才讓虛擬ip對應,但是還是多對一的方式,所以pool內可以只設一個ip

#conf t

)#ip nat pool d_nat 200.2.2.10 200.2.2.200 netmask 255.255.255.0 (d_nat是表示pool的name可以任意修改,200.2.2.10 200.2.2.200是表示那些要對應的實體ip,255.255.255.0是這個實體ip的netmask)

)#access-list 20 permit 192.168.3.0 0.0.0.255 (這是設定要被處理的那些虛擬ip網段)

)#ip nat inside source list 20 pool d_nat overload (這是將上面的實體ip的pool和允許要進行map之虛擬ip的網段作結合,這樣router才知道要作nat)

)#int fa 0/0     (設定完上面的對應後,要在lan port上設inside,在wan port上設outside,如果有多個lan,一個wan,每個lan都要設inside,然後在wan上outside)

)#ip nat inside

)#int se 0/0/1

)#ip nat outside

 

pat另一個作法是透過一個int 介面中的實體ip來讓虛擬ip對應,但是也是多對一的方式

#conf t

)#access-list 30 permit 192.168.3.0 0.0.0.255 (這是設定要被處理的那些虛擬ip網段)

)#ip nat inside source list 30 interface s0/0/1 overload (這是將上面的實體ip的pool和允許要進行map之虛擬ip的網段作結合,這樣router才知道要作nat)

)#int fa 0/0     (設定完上面的對應後,要在lan port上設inside,在wan port上設outside,如果有多個lan,一個wan,每個lan都要設inside,然後在wan上outside)

)#ip nat inside

)#int se 0/0/1

)#ip nat outside

本 著作 係採用創用 CC 姓名標示-非商業性-相同方式分享 3.0 台灣 授權條款授權


Cisco dhcp

資訊科技 — 作者 wkb @ 16:47

可以在router上作dhcp server的功能

 

#conf t

)#ip dhcp pool xxx (前面xxx設定是pool的名稱)

)#network 192.168.1.0 255.255.255.0 (router上預設會從1.1的ip開始發放)

)#default-router 192.168.1.254

)#exit (離開此pool)

)#ip dhcp excluded-address 192.168.1.250 192.168.1.254 (可以將前面的ip不發放)

本 著作 係採用創用 CC 姓名標示-非商業性-相同方式分享 3.0 台灣 授權條款授權


Powered by LifeType